ことさら−古都プログラマーの更級日記

京都でお寺を回りながら御朱印集めをしていたエンジニアのブログ。おもに技術的なはなしとか日常的なはなし。たまにカメラの話や競馬の話も書きます。

Mac

Warning (el-get): Your Emacs doesn't support HTTPS (TLS). と言われた時の対処 for Mac - HTTPS (TLS) 対応版のEmacsをインストールしたい

いきさつ el-getを使っていると以下のようなWarningが出ることがある。 Warning (el-get): Your Emacs doesn't support HTTPS (TLS). まあWarningなので無視しても問題ないっちゃ問題ないのだが、いちいち出てくるのがうざい。EmacsをTLSに対応させることで…

brew upgrade したら Emacs がターミナル上じゃなくてGUIで起動するようになったのでターミナルで起動するように戻したい

いきさつ brew upgrade したら Emacs のバージョンが25になり、ターミナル上ではなくGUIで起動するようになった。GUIで起動しても大きな不便はないだろうと思っていたのだが、以下の問題があった。 Google日本語入力IMEが働かない(日本語が入力できない) g…

MacでHomebrewを使っていて、コマンドラインから叩くphpのバージョンがなんかおかしくなった場合の対処

概要 ある日 composer install するとこんな警告が出た phpunit/phpunit 5.7.21 requires php ^5.6 || ^7.0 -> your PHP version (5.5.20) does not satisfy that requirement. phpunit 5.7.21 を利用するには php5.6 以上または php7.0 以上が必要だが、あ…